Back
Maintenance

Digital Ocean downtime

Completed 13 Aug at 03:47pm CEST.

Started

DigitalOcean, our host, experienced issues in our datacenter.

Posted 13 Aug at 03:47pm CEST.
Completed

Maintenance completed

Posted 13 Aug at 03:47pm CEST.