Back
Downtime

Some services are unreliable
Started 28 Oct at 10:00am CEST, resolved 28 Oct at 12:46pm CEST.
Resolved
Our servers should be reliable again.
Posted 28 Oct at 12:46pm CEST.

Created
We are currently expierencing some issues causing unreliability in our primary servers. Please hold as we resolve this.
Posted 28 Oct at 10:00am CEST.