Back
Maintenance

Server Maintenance
Completed 15 Apr at 08:53pm CEST.
Completed
We have completed the server maintenance. Everything should be up as normal again!
Posted
15 Apr at 08:53pm CEST.
Updated
We're still working on doing server maintenance. We'll let you know when we're finished.
Posted
15 Apr at 06:28pm CEST.

Started
We're currently working on improving the servers! We except some downtime overall due to having to reboot some services. However we are doing our best to do minimal downtime!
Posted
15 Apr at 03:27pm CEST.