Back
Maintenance

Server move

Completed 27 May at 08:35pm CEST.

Primary API Avatars Load balancer
Completed

Maintenance completed

Posted 27 May at 08:35pm CEST.
Started

We are moving our servers to a new location, please stand by as we try to do this with minimal downtime as possible!

Posted 27 May at 10:34am CEST.